package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-\w ]+(,[-\w ]+)+$`)
var str = `
1000,two thousand,3000
1000 , 2000 , 3000
First Option,2Nd Option, THIRD Option
Single Value
1000 ,, 2000 , 3000
1000 , 2000 , 3000,
1000 , 2000 , 3000,,
,,1000 , 2000 , 3000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}