# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+)\. ?(.+?)(?:value|vlaue|balue|valie): ?(.+?)[\n\r]{2,}//gms;t' <<< "Some junk data
More junk data
1. fairly long key, all on one line
value: some other text with spaces and stuff
Some junk data
More junk data
2. hey look! another long
and broken key. on two lines
value: a different value with some different information
Some junk data
More junk data
3. hey look! another long line. on a line
value: a different value
broken, with some different information
Some junk data
More junk data "