const regex = /^(\d+)\. ?(.+?)(?:value|vlaue|balue|valie): ?(.+?)[\n\r]{2,}/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\. ?(.+?)(?:value|vlaue|balue|valie): ?(.+?)[\\n\\r]{2,}', 'gms')
const str = `Some junk data
More junk data
1. fairly long key, all on one line
value: some other text with spaces and stuff
Some junk data
More junk data
2. hey look! another long
and broken key. on two lines
value: a different value with some different information
Some junk data
More junk data
3. hey look! another long line. on a line
value: a different value
broken, with some different information
Some junk data
More junk data `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);