import re
regex = re.compile(r"^(\d+)\. ?(.+?)(?:value|vlaue|balue|valie): ?(.+?)[\n\r]{2,}", flags=re.MULTILINE | re.DOTALL)
test_str = ("Some junk data\n"
"More junk data \n\n"
"1. fairly long key, all on one line\n"
"value: some other text with spaces and stuff\n\n"
"Some junk data\n\n"
"More junk data \n\n"
"2. hey look! another long \n"
"and broken key. on two lines\n"
"value: a different value with some different information\n\n"
"Some junk data\n"
"More junk data \n\n"
"3. hey look! another long line. on a line\n"
"value: a different value \n"
"broken, with some different information\n\n"
"Some junk data\n"
"More junk data ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)