using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td(.+|)(class=""myClass"")(.+|)><\/td>";
string input = @"<td>I Dont want this</td>
<td class=""myClass"">I want this</td>
<td class=""myClass"" id=""myID"">I want this</td>
<td style=""border-top-width: 0px; class=""myClass"">I want this</td>
<td class=""niggaWhat"" yoh how are you>as long as</td>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}