$re = '/<td(.+|)(class="myClass")(.+|)><\/td>/';
$str = '<td>I Dont want this</td>
<td class="myClass">I want this</td>
<td class="myClass" id="myID">I want this</td>
<td style="border-top-width: 0px; class="myClass">I want this</td>
<td class="niggaWhat" yoh how are you>as long as</td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);