re = /<td(.+|)(class="myClass")(.+|)><\/td>/
str = '<td>I Dont want this</td>
<td class="myClass">I want this</td>
<td class="myClass" id="myID">I want this</td>
<td style="border-top-width: 0px; class="myClass">I want this</td>
<td class="niggaWhat" yoh how are you>as long as</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end