import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td(.+|)(class=\"myClass\")(.+|)><\\/td>";
final String string = "<td>I Dont want this</td>\n"
+ "<td class=\"myClass\">I want this</td>\n"
+ "<td class=\"myClass\" id=\"myID\">I want this</td>\n"
+ "<td style=\"border-top-width: 0px; class=\"myClass\">I want this</td>\n"
+ "<td class=\"niggaWhat\" yoh how are you>as long as</td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}