using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([01][0-9]|2[0-3]):[0-5][0-9]
";
string input = @"20:59
00:59
01:01
10:30
00:00
24:59
30:01
00:60
05:122
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}