package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[?:!.,;'\"«»]+|[?:!.,;'\"«»]+$`)
var str = `«Be!!»
"Here!!!"
«I`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}