re = /^[?:!.,;'\"«»]+|[?:!.,;'\"«»]+$/m
str = '«Be!!»
"Here!!!"
«I'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result