#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^(?!.*po box|care po|cma|gpo box|locked bag|ms|private bag|rsd|rmb|rms|cpa|care of post office|community mail agent|community mail bag|general post office box|locked mail bag service|mail service|post office box|poste restante|private mail bag service|roadside delivery|roadside mail bag|roadside mail box|roadside mail service|community postal agent).*$"
Local $sString = "asdasdqweq qwe qeqw ewqe qwe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")