import Foundation
let pattern = #"^(?!.*po box|care po|cma|gpo box|locked bag|ms|private bag|rsd|rmb|rms|cpa|care of post office|community mail agent|community mail bag|general post office box|locked mail bag service|mail service|post office box|poste restante|private mail bag service|roadside delivery|roadside mail bag|roadside mail box|roadside mail service|community postal agent).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"asdasdqweq qwe qeqw ewqe qwe"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)