import re
regex = re.compile(r"^(?!.*po box|care po|cma|gpo box|locked bag|ms|private bag|rsd|rmb|rms|cpa|care of post office|community mail agent|community mail bag|general post office box|locked mail bag service|mail service|post office box|poste restante|private mail bag service|roadside delivery|roadside mail bag|roadside mail box|roadside mail service|community postal agent).*$", flags=re.IGNORECASE)
test_str = "asdasdqweq qwe qeqw ewqe qwe"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")