$re = '/^(?!.*po box|care po|cma|gpo box|locked bag|ms|private bag|rsd|rmb|rms|cpa|care of post office|community mail agent|community mail bag|general post office box|locked mail bag service|mail service|post office box|poste restante|private mail bag service|roadside delivery|roadside mail bag|roadside mail box|roadside mail service|community postal agent).*$/i';
$str = 'asdasdqweq qwe qeqw ewqe qwe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);