using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\d{1,2}[\/-]){2}(?:\d{4}|\d{2}))";
string input = @"ASTA n° 30 | 13/12/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 1/12/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/1/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13-12-2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/12-2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/12/15 ore 10.00 | Arte Moderna & Contemporanea";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}