import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\d{1,2}[\\/-]){2}(?:\\d{4}|\\d{2}))";
final String string = "ASTA n° 30 | 13/12/2015 ore 10.00 | Arte Moderna & Contemporanea\n"
+ "ASTA n° 30 | 1/12/2015 ore 10.00 | Arte Moderna & Contemporanea\n"
+ "ASTA n° 30 | 13/1/2015 ore 10.00 | Arte Moderna & Contemporanea\n"
+ "ASTA n° 30 | 13-12-2015 ore 10.00 | Arte Moderna & Contemporanea\n"
+ "ASTA n° 30 | 13/12-2015 ore 10.00 | Arte Moderna & Contemporanea\n"
+ "ASTA n° 30 | 13/12/15 ore 10.00 | Arte Moderna & Contemporanea";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}