use strict;
my $str = 'ASTA n° 30 | 13/12/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 1/12/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/1/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13-12-2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/12-2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/12/15 ore 10.00 | Arte Moderna & Contemporanea';
my $regex = qr/((?:\d{1,2}[\/-]){2}(?:\d{4}|\d{2}))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}