// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:\d{1,2}[\/-]){2}(?:\d{4}|\d{2}))").unwrap();
let string = "ASTA n° 30 | 13/12/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 1/12/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/1/2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13-12-2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/12-2015 ore 10.00 | Arte Moderna & Contemporanea
ASTA n° 30 | 13/12/15 ore 10.00 | Arte Moderna & Contemporanea";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}