# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<div|<a)( *id="[^"]+")/ /g;t' <<< "<p id=\"keepthis\"> text</p><div id=\"foo\">text</div><div id=\"bar\">more text</div><a id=\"red\"href=\"page6.php\">Page 6</a><a id=\"green\"href=\"page7.php\">Page 7</a>"