re = /(?<=<div|<a)( *id="[^"]+")/
str = '<p id="keepthis"> text</p><div id="foo">text</div><div id="bar">more text</div><a id="red"href="page6.php">Page 6</a><a id="green"href="page7.php">Page 7</a>'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result