import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<div|<a)( *id=\"[^\"]+\")";
final String string = "<p id=\"keepthis\"> text</p><div id=\"foo\">text</div><div id=\"bar\">more text</div><a id=\"red\"href=\"page6.php\">Page 6</a><a id=\"green\"href=\"page7.php\">Page 7</a>";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}