# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<div|<a)( *id=\"[^\"]+\")"
test_str = "<p id=\"keepthis\"> text</p><div id=\"foo\">text</div><div id=\"bar\">more text</div><a id=\"red\"href=\"page6.php\">Page 6</a><a id=\"green\"href=\"page7.php\">Page 7</a>"
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.