$re = '/A{4}\([a-zA-Z]{4},\d\)/';
$str = 'AAAA(abcd,6)
AAAA(WXYZ,2)
AAAA(abcd,6,9)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);