// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"A{4}\([a-zA-Z]{4},\d\)").unwrap();
let string = "AAAA(abcd,6)
AAAA(WXYZ,2)
AAAA(abcd,6,9)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}