import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\s]*(.*?)[\\s]*$";
final String string = " Lorem ipsum \n\n\n"
+ " F.F.Coppola \n\n"
+ " Kilgore : Smell that? You smell that?\n"
+ " Lance : What?\n"
+ " Kilgore : Napalm, son. Nothing else in the world smells like that. I love the smell of napalm in the morning. You know, one time we had a hill bombed, for 12 hours. When it was all over, I walked up. We didn't find one of 'em, not one stinkin' dink body.\n\n\n"
+ "Robert Duvall as Lieutenant Colonel Bill Kilgore - IMDb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}