// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\s]*(.*?)[\s]*$").unwrap();
let string = " Lorem ipsum
F.F.Coppola
Kilgore : Smell that? You smell that?
Lance : What?
Kilgore : Napalm, son. Nothing else in the world smells like that. I love the smell of napalm in the morning. You know, one time we had a hill bombed, for 12 hours. When it was all over, I walked up. We didn't find one of 'em, not one stinkin' dink body.
Robert Duvall as Lieutenant Colonel Bill Kilgore - IMDb";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}