const regex = /^[\s]*(.*?)[\s]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\s]*(.*?)[\\s]*$', 'gm')
const str = ` Lorem ipsum
F.F.Coppola
Kilgore : Smell that? You smell that?
Lance : What?
Kilgore : Napalm, son. Nothing else in the world smells like that. I love the smell of napalm in the morning. You know, one time we had a hill bombed, for 12 hours. When it was all over, I walked up. We didn't find one of 'em, not one stinkin' dink body.
Robert Duvall as Lieutenant Colonel Bill Kilgore - IMDb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}