re = /^[\s]*(.*?)[\s]*$/m
str = ' Lorem ipsum
F.F.Coppola
Kilgore : Smell that? You smell that?
Lance : What?
Kilgore : Napalm, son. Nothing else in the world smells like that. I love the smell of napalm in the morning. You know, one time we had a hill bombed, for 12 hours. When it was all over, I walked up. We didn\'t find one of \'em, not one stinkin\' dink body.
Robert Duvall as Lieutenant Colonel Bill Kilgore - IMDb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end