use strict;
my $str = 'http://xevens.com/projects/xe/wp-content/uploads/2014/10/alaska_winter_nights-1366x768-300x168.jpg
';
my $regex = qr/-\d+[Xx]\d+\./p;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";