// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-\d+[Xx]\d+\.").unwrap();
let string = "http://xevens.com/projects/xe/wp-content/uploads/2014/10/alaska_winter_nights-1366x768-300x168.jpg
";
let substitution = ".";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}