re = /-\d+[Xx]\d+\./
str = 'http://xevens.com/projects/xe/wp-content/uploads/2014/10/alaska_winter_nights-1366x768-300x168.jpg
'
subst = '.'
result = str.sub(re, subst)
# Print the result of the substitution
puts result