#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\D+_"
Local $sString = "name_001.png" & @CRLF & _
"na-m-e_001_tr.png" & @CRLF & _
"name_name_001.png"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)