const regex = /^\D+_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\D+_', 'gm')
const str = `name_001.png
na-m-e_001_tr.png
name_name_001.png`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);