#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "'([^']*)'\s*(?=\bis\b)"
Local $sString = "RECOVERY: 'XXXXXXXXX' is UP" & @CRLF & _
"PROBLEM: 'ABABABAB' on 'XXXXXXXXX' is WARNING" & @CRLF & _
"PROBLEM: 'XXXXXXXXX' is DOWN" & @CRLF & _
"RECOVERY: 'ABABABAB' on 'XXXXXXXXX' is OK" & @CRLF & _
"PROBLEM: 'ABABABAB' on 'XXXXXXXXX' is DOWN"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")