$re = '/\'([^\']*)\'\s*(?=\bis\b)/';
$str = 'RECOVERY: \'XXXXXXXXX\' is UP
PROBLEM: \'ABABABAB\' on \'XXXXXXXXX\' is WARNING
PROBLEM: \'XXXXXXXXX\' is DOWN
RECOVERY: \'ABABABAB\' on \'XXXXXXXXX\' is OK
PROBLEM: \'ABABABAB\' on \'XXXXXXXXX\' is DOWN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);