import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'([^']*)'\\s*(?=\\bis\\b)";
final String string = "RECOVERY: 'XXXXXXXXX' is UP\n"
+ "PROBLEM: 'ABABABAB' on 'XXXXXXXXX' is WARNING\n"
+ "PROBLEM: 'XXXXXXXXX' is DOWN\n"
+ "RECOVERY: 'ABABABAB' on 'XXXXXXXXX' is OK\n"
+ "PROBLEM: 'ABABABAB' on 'XXXXXXXXX' is DOWN";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}