using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[AaEeIiOoUuYy]";
string substitution = @"oodle";
string input = @"Smith";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}