use strict;
my $str = 'Smith';
my $regex = qr/[AaEeIiOoUuYy]/p;
my $subst = 'oodle';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";