$re = '/[AaEeIiOoUuYy]/';
$str = 'Smith';
$subst = "oodle";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;