package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[AaEeIiOoUuYy]`)
var str = `Smith`
var substitution = "oodle"
fmt.Println(re.ReplaceAllString(str, substitution))
}