using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(longword1|longword2|longword3)\b.*?\b(?!\1\b)((?1))\b.*?\b(?!(?:\1|\2)\b)(?1)\b";
string input = @"A longword1 B longword2 C longword3 D
^--------------------------------^
A longword2 B longword1 C longword3 D
^-------------------------------^
A longword3 B longword2 C longword1 D
^-------------------------------^
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}