$re = '/\b(longword1|longword2|longword3)\b.*?\b(?!\1\b)((?1))\b.*?\b(?!(?:\1|\2)\b)(?1)\b/m';
$str = 'A longword1 B longword2 C longword3 D
^--------------------------------^
A longword2 B longword1 C longword3 D
^-------------------------------^
A longword3 B longword2 C longword1 D
^-------------------------------^
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);