import re
regex = re.compile(r"\b(longword1|longword2|longword3)\b.*?\b(?!\1\b)((?1))\b.*?\b(?!(?:\1|\2)\b)(?1)\b", flags=re.MULTILINE)
test_str = ("A longword1 B longword2 C longword3 D\n"
" ^--------------------------------^\n\n"
"A longword2 B longword1 C longword3 D\n"
" ^-------------------------------^\n\n"
"A longword3 B longword2 C longword1 D\n"
" ^-------------------------------^\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")