import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<operator>[+\\-])?(?:(?<dice>(?<numberOfDice>[\\d]+)?[dD](?<faces>[\\d]+)(?<explode>![\\d]*)?(?<implode>¡[\\d]*)?(?<selective>[kd][\\d]+)?)|(?<constant>[\\d]+))";
final String string = "d4\n"
+ "1d4\n"
+ "1d20-10\n"
+ "2d6+1d8\n"
+ "3d10k2\n"
+ "3d10d2\n"
+ "6d6!\n"
+ "6d6!5\n"
+ "d100!96¡5\n"
+ "d6¡\n"
+ "d20¡2\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}