$re = '/(?<operator>[+\-])?(?:(?<dice>(?<numberOfDice>[\d]+)?[dD](?<faces>[\d]+)(?<explode>![\d]*)?(?<implode>¡[\d]*)?(?<selective>[kd][\d]+)?)|(?<constant>[\d]+))/m';
$str = 'd4
1d4
1d20-10
2d6+1d8
3d10k2
3d10d2
6d6!
6d6!5
d100!96¡5
d6¡
d20¡2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);