const regex = /(?<operator>[+\-])?(?:(?<dice>(?<numberOfDice>[\d]+)?[dD](?<faces>[\d]+)(?<explode>![\d]*)?(?<implode>¡[\d]*)?(?<selective>[kd][\d]+)?)|(?<constant>[\d]+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<operator>[+\\-])?(?:(?<dice>(?<numberOfDice>[\\d]+)?[dD](?<faces>[\\d]+)(?<explode>![\\d]*)?(?<implode>¡[\\d]*)?(?<selective>[kd][\\d]+)?)|(?<constant>[\\d]+))', 'gm')
const str = `d4
1d4
1d20-10
2d6+1d8
3d10k2
3d10d2
6d6!
6d6!5
d100!96¡5
d6¡
d20¡2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}