using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^.0-]\d+|\d)$";
string substitution = @"";
string input = @"111111111111111999999999999999990000000000000000333333333333333332
10
11
2
00
-1
-22
.5
1.4
0.1
0.
0-
-0
000.4
022345
0
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}