$re = '/^([^.0-]\d+|\d)$/m';
$str = '111111111111111999999999999999990000000000000000333333333333333332
10
11
2
00
-1
-22
.5
1.4
0.1
0.
0-
-0
000.4
022345
0
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;