import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^.0-]\\d+|\\d)$";
final String string = "111111111111111999999999999999990000000000000000333333333333333332\n"
+ "10\n"
+ "11\n"
+ "2\n"
+ "00\n"
+ "-1\n"
+ "-22\n"
+ ".5\n"
+ "1.4\n"
+ "0.1\n"
+ "0.\n"
+ "0-\n"
+ "-0\n"
+ "000.4\n"
+ "022345\n"
+ "0\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}